注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

c32's blog

每天学习一点点,每天进步一点点.

 
 
 
 
 

日志

 
 

使用多常量匹配 正则匹配同一文本  

2013-11-25 11:10:04|  分类: 易语言 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
.版本 2
.支持库 iext

临时文本 = 彗星HTTP读文本 (URL地址.内容)
c32.创建 (#旺旺匹配, 临时文本)
.计次循环首 (c32.取匹配数量 (), i)
    临时表项 = 超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (临时表项, 0, c32.取子匹配文本 (i, 2))
    超级列表框1.置标题 (临时表项, 1, c32.取子匹配文本 (i, 1))
    处理事件 ()
.计次循环尾 ()
' ====================下面是地区匹配================================
c32.创建 (#地区匹配, 临时文本)
.计次循环首 (c32.取匹配数量 (), i)
    超级列表框1.置标题 (i - 1, 3, c32.取子匹配文本 (i, 1))
    处理事件 ()
.计次循环尾 ()
' ====================下面是URL匹配===========取消使用==============
' c32.创建 (#URL匹配, 临时文本)
' 计次循环首 (c32.取匹配数量 (), i)
' 超级列表框1.置标题 (i - 1, 2, c32.取子匹配文本 (i, 1))
' 处理事件 ()
' ====================下面是价格匹配================================
c32.创建 (#价格匹配, 临时文本)
.计次循环首 (c32.取匹配数量 (), i)
    超级列表框1.置标题 (i - 1, 2, c32.取子匹配文本 (i, 1))
    处理事件 ()
.计次循环尾 ()

  评论这张
 
阅读(18)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017