注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

c32's blog

每天学习一点点,每天进步一点点.

 
 
 
 
 

日志

 
 

超级列表框 导出到 xls  

2013-11-25 11:08:36|  分类: 易语言 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
.版本 2
.支持库 eExcel2000
.支持库 iext
.支持库 shell

.子程序 _导出到xls表格_被选择
.局部变量 局部_计次1, 整数型
.局部变量 局部_计次, 整数型
.局部变量 局部_导出头, 文本型, , "0"

通用对话框_公用.类型 = 1
.如果真 (通用对话框_公用.打开 () = 假)
    返回 ()
.如果真结束
Excel程序1.创建 ()
Excel工作簿1.置程序 (Excel程序1)
Excel工作簿1.激活工作簿 ()
Excel工作簿1.表格序号 = 1
局部_导出头 = { “旺旺号”, “店铺地址”, “价格”, “地区”, “电话”, “平台”, “月销量”, “家庭电话”, “小灵通” }
.计次循环首 (取数组成员数 (局部_导出头), 局部_计次1)
    Excel工作簿1.首单元格 = 字符 (97 + 局部_计次1 - 1) + 到文本 (1)
    Excel工作簿1.尾单元格 = 字符 (97 + 局部_计次1 - 1) + 到文本 (1)
    Excel工作簿1.内容格式 = “@”
    Excel工作簿1.内容 = 局部_导出头 [局部_计次1]
.计次循环尾 ()
.计次循环首 (超级列表框1.取表项数 (), 局部_计次)
    处理事件 ()
    .计次循环首 (取数组成员数 (局部_导出头), 局部_计次1)
        Excel工作簿1.首单元格 = 字符 (97 + 局部_计次1 - 1) + 到文本 (局部_计次 + 1)
        Excel工作簿1.尾单元格 = 字符 (97 + 局部_计次1 - 1) + 到文本 (局部_计次 + 1)
        Excel工作簿1.内容格式 = “@”
        Excel工作簿1.内容 = 超级列表框1.取标题 (局部_计次 - 1, 局部_计次1 - 1)
    .计次循环尾 ()

.计次循环尾 ()
Excel工作簿1.保存 (通用对话框_公用.文件名)
_启动窗口.Excel工作簿1.关闭 ()
_启动窗口.Excel工作簿1.释放 ()
_启动窗口.Excel程序1.退出 ()
_启动窗口.Excel程序1.释放 ()
信息框 (“导出成功!”, #信息图标, )
执行 (4, 通用对话框_公用.文件名, , )
返回 ()

  评论这张
 
阅读(121)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017