注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

c32's blog

每天学习一点点,每天进步一点点.

 
 
 
 
 

日志

 
 

Ubuntu上安装vim不能安装的问题,“下列的软件包有不能满足的依赖关系”  

2014-04-15 12:13:22|  分类: ubuntu |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
前阵子,刚安装Ubuntu时,安装vim的问题,现在些出来分享一下。
apt-get install vim
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的软件包有不能满足的依赖关系:
vim: 依赖: vim-common (= 1:7.1.314-3ubuntu3.1) 但是 2:7.2.079-1ubuntu5 正要被安装
E: 无法安装的软件包

     这种问题就应该是软件源的问题,源中的版本比较低;依赖的版本号比正要安装的版本号要低导致没法安装。
只需要将原来软件源删除,用新的软件源替换一下就可以了。
做法见这里:http://wiki.ubuntu.org.cn/%E5%A6%82%E4%BD%95%E4%BD%BF%E7%94%A8%E6%88%91%E4%BB%AC%E6%8E%A8%E8%8D%90%E7%9A%84%E6%BA%90

sudo gedit /etc/apt/sources.list
写上软件源后,再刷新一下,注意一定要刷新,运行:
sudo apt-get update
(我开始一次就是因为没有刷新而没有解决Vim安装失败的问题)
  评论这张
 
阅读(26)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017