注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

c32's blog

每天学习一点点,每天进步一点点.

 
 
 
 
 

日志

 
 

git更新metasploit  

2014-07-17 12:13:27|  分类: metasploit |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
BT5Metasploit更新真是一个头痛的问题。ruby版本是个大问题。本来BT5带了一个ruby是1.9.2dev,但是msf也有一个,是1.9.1这就来麻烦了,一些软件要求ruby必须大于等于1.9.2但是呢msf自己又有一个ruby是1.9.2。当你看到这个版本问题的时候,往往会想到去更新系统的ruby版本,但是却无济于事。
git init
rm -rf /opt/metasploit/msf3
git clone https://github.com/rapid7/metasploit-framework /opt/metasploit/msf3
修改相关配置
1
vim /opt/metasploit/ruby/lib/ruby/1.9.1/x86_64-linux/rbconfig.rb

[修改第56行,将-l及后面的都注释掉,注意-l前面要加引号,-l前面开始注释]

rubymsf

修改为下面的模样即可

rubymsf1

 

然后继续。。

1
2
3
gem install bundle
cd /opt/metasploit/msf3
/opt/metasploit/ruby/bin/bundle install









  评论这张
 
阅读(53)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017