注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

c32's blog

每天学习一点点,每天进步一点点.

 
 
 
 
 

日志

 
 

2Bizbox 发货单查询结果并批量打印 未完成版  

2017-04-05 23:39:44|  分类: 2BizBox |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
需求1:根据不同的发货单号生成不同的xls文件    相同发货单号多行数据为1个XLS
需求2,:点击按钮直接进行打印

.版本 2
.支持库 EThread
.支持库 mysql
.支持库 spec
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 ji_mysql, 整数型

.子程序 __启动窗口_创建完毕

启动线程 (&mysql, , )

.子程序 mysql, 逻辑型

ji_mysql = 连接MySql (“192.168.1.10”, “root”, “root.”, “bb2_headas”, 3306)
执行SQL语句 (ji_mysql, “SET NAMES GBK”)
.如果 (ji_mysql = 1)
    调试输出 (“sb”)
    信息框 (“no sql”, 0, , )
.否则
    调试输出 (“SQL OK”)
    sql状态.标题 = “SQL OK”
.如果结束
返回 (真)

.子程序 _查询订单_被单击
.局部变量 ju_jlj_danhao, 整数型
.局部变量 i, 整数型
.局部变量 txt, 文本型, , "19", 根据查询条数适量增加

ju_jlj_danhao = 查找记录 (ji_mysql, “my_print_list left join sois on my_print_list.order_num=sois.sn left join so on sois.so=so.so left join ab on so.id=ab.id”, “ab.name,sois.date_shipped,ab.phone,ab.addr1,sois.sn,so.so,ab.salesman_id,sois.si,sois.pn,sois.mn,sois.description,sois.qty,sois.qty_ship,sois.unit,sois.comments,sois.notes,so.comments,so.notes”, “my_print_list.order_num like'” + “%” + 编辑框1.内容 + “%” + “'”, “order_num ASC”)
调试输出 (取记录集行数 (ju_jlj_danhao))
.计次循环首 (取记录集行数 (ju_jlj_danhao), i)
    读字段值 (ju_jlj_danhao, “name”, txt [1])  ' 客户名称
    读字段值 (ju_jlj_danhao, “date_shipped”, txt [2])  ' 发货时间
    读字段值 (ju_jlj_danhao, “phone”, txt [3])  ' 客户电话
    读字段值 (ju_jlj_danhao, “addr1”, txt [4])  ' 客户地址
    读字段值 (ju_jlj_danhao, “sn”, txt [5])  ' 发货单号
    读字段值 (ju_jlj_danhao, “so”, txt [6])  ' 销售单号
    读字段值 (ju_jlj_danhao, “salesman_id”, txt [7])  ' 业务经理
    读字段值 (ju_jlj_danhao, “si”, txt [8])  ' 项号
    读字段值 (ju_jlj_danhao, “pn”, txt [9])  ' 料号
    读字段值 (ju_jlj_danhao, “mn”, txt [10])  ' 商品名称
    读字段值 (ju_jlj_danhao, “description”, txt [11])  ' 商品描述
    读字段值 (ju_jlj_danhao, “qty”, txt [12])  ' 订单数量
    读字段值 (ju_jlj_danhao, “salesman_id”, txt [13])  ' 未发订单数量
    读字段值 (ju_jlj_danhao, “qty_ship”, txt [14])  ' 本次已发数量
    读字段值 (ju_jlj_danhao, “unit”, txt [15])  ' 单位
    读字段值 (ju_jlj_danhao, “comments”, txt [16])  ' 发货单备注
    读字段值 (ju_jlj_danhao, “notes”, txt [17])  ' 发货单私有备注
    读字段值 (ju_jlj_danhao, “comments”, txt [18])  ' 销售单备注
    读字段值 (ju_jlj_danhao, “notes”, txt [19])  ' 销售单私有备注
    调试输出 (txt)

    到下一行 (ju_jlj_danhao)
    调试输出 (“添加成功”)
    超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 0, txt [1])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 1, txt [2])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 2, txt [3])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 3, txt [4])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 4, txt [5])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 5, txt [6])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 6, txt [7])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 7, txt [8])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 8, txt [9])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 9, txt [10])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 10, txt [11])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 11, txt [12])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 12, txt [13])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 13, txt [14])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 14, txt [15])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 15, txt [16])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 16, txt [17])
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 17, txt [18])
.计次循环尾 ()
' 暂停 ()

.子程序 _导出订单_被单击
.局部变量 a, 讯手_字段型
.局部变量 字段, 讯手_字段型, , "0"
.局部变量 Excel, 类_Excel
.局部变量 i, 整数型
.局部变量 t, 文本型
.局部变量 表名, 文本型
.局部变量 x, 整数型
.局部变量 sql, 文本型

表名 = “Sheet1$”
.计次循环首 (超级列表框1.取列数 (), i)
    t = t + 超级列表框1.取列标题 (i - 1) + “,3,255|”
.计次循环尾 ()
.如果真 (Excel.初始化_ (数据库连接1, 记录集1, “C:\Users\Administrator\Desktop” + “\123.xls”, 1))
    Excel.新建表_ (表名 + “@” + t)
    Excel.打开表_ (表名, 2)
    .计次循环首 (超级列表框1.取表项数 (), i)
        Excel.新增_ ()
        .计次循环首 (超级列表框1.取列数 (), x)
            t = 超级列表框1.取标题 (i - 1, x - 1)
            Excel.写文本_ (到文本 (x - 1), t)
        .计次循环尾 ()
    .计次循环尾 ()
    Excel.更新_ ()
.如果真结束

  评论这张
 
阅读(23)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017